Skip to content

Simulating RIP

Simulating RIP
Advance Computer Network MSc IT Part 1 Practicals

Network topology

Configuring IP on R1
R1#en
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#
*Mar  1 00:02:33.451: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:02:34.451: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#int loopback 9
R1(config-if)#
*Mar  1 00:02:48.523: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback9, changed state to up
R1(config-if)#ip add 9.9.9.9 255.255.255.255
R1(config-if)#no shutdown
R1(config-if)#exit
Setting up RIP on R1
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 9.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#no auto-summary
R1(config-router)#exit
R1(config)#exit
Configuring IP on R2
Connected to Dynamips VM “R2” (ID 1, type c3725) – Console port
Press ENTER to get the prompt.

R2#en
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#interface f0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Mar  1 00:04:21.615: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:04:22.615: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#interface f0/1
R2(config-if)#ip address 192.168.1.5 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Mar  1 00:05:04.099: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar  1 00:05:05.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config-if)#exit

Setting up RIP on R2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 192.168.1.0
R2(config-router)#no auto-summary
R2(config-router)#exit
R2(config)#exit
Configuring IP on R3
Connected to Dynamips VM “R3” (ID 2, type c3725) – Console port
Press ENTER to get the prompt.
R3#en
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.1.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#
*Mar  1 00:05:51.287: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:05:52.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#interface loopback 11
R3(config-if)#ip a
*Mar  1 00:08:42.111: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback11, changed state to up
R3(config-if)#ip address 11.11.11.11 255.255.255.255
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#exit
R3#

Setting up RIP on R3
*Mar  1 00:11:36.179: %SYS-5-CONFIG_I: Configured from console by console
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 11.0.0.0
R3(config-router)#network 192.168.1.0
R3(config-router)#no auto-summary
R3(config-router)#exit
R3(config)#exit
Testing network reachability
Router R1#
*Mar  1 0010:30.735: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip int bri
Interface                       IP-Address      OK?      Method Status                           Protocol
FastEthernet0/0            192.168.1.1     YES      manual up                                   up
FastEthernet0/1            unassigned      YES      unset  administratively down     down
Loopback9                    9.9.9.9             YES     manual up                                   up
R1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/44/104 ms
R1#ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/46/132 ms
R1#ping 192.168.1.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/72/140 ms
R1#show ip rip database
9.0.0.0/8    auto-summary
9.9.9.9/32    directly connected, Loopback9
11.0.0.0/8    auto-summary
11.11.11.11/32
    [2] via 192.168.1.2, 00:00:27, FastEthernet0/0
192.168.1.0/24    auto-summary
192.168.1.0/30    directly connected, FastEthernet0/0
192.168.1.4/30
    [1] via 192.168.1.2, 00:00:27, FastEthernet0/0

R1#show ip protocols
Routing Protocol is “rip”
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 27 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    Loopback9             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    9.0.0.0
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.2          120      00:00:05
  Distance: (default is 120)

Output Screens:

Router R2#
R2#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES manual up                    up
FastEthernet0/1            192.168.1.5     YES manual up                    up

R2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/47/72 ms

R2#ping 192.168.1.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/43/80 ms

R2#ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

R2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

R2#show ip rip database
9.0.0.0/8    auto-summary
9.9.9.9/32
    [1] via 192.168.1.1, 00:00:09, FastEthernet0/0
11.0.0.0/8    auto-summary
11.11.11.11/32
    [1] via 192.168.1.6, 00:00:04, FastEthernet0/1
192.168.1.0/24    auto-summary
192.168.1.0/30    directly connected, FastEthernet0/0
192.168.1.4/30    directly connected, FastEthernet0/1
R2#show ip protocols
Routing Protocol is “rip”
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 25 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    FastEthernet0/1       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.1          120      00:00:23
    192.168.1.6          120      00:00:21
  Distance: (default is 120)
R2#

Output Screens:

Router R3#
R3#show ip int bri
Interface                       IP-Address      OK?    Method Status                            Protocol
FastEthernet0/0            192.168.1.6     YES    manual up                                     up
FastEthernet0/1            unassigned      YES    unset  administratively down        down
Loopback11                 11.11.11.11     YES    manual up                                      up

R3#ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/50/68 ms

R3#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/46/96 ms
R3#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/63/96 ms

R3#show ip rip database
9.0.0.0/8    auto-summary
9.9.9.9/32
    [2] via 192.168.1.5, 00:00:10, FastEthernet0/0
11.0.0.0/8    auto-summary
11.11.11.11/32    directly connected, Loopback11
192.168.1.0/24    auto-summary
192.168.1.0/30
    [1] via 192.168.1.5, 00:00:10, FastEthernet0/0
192.168.1.4/30    directly connected, FastEthernet0/0

R3#show ip protocols
Routing Protocol is “rip”
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 12 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    Loopback11            2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    11.0.0.0
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.5          120      00:00:23
  Distance: (default is 120)
Output Screens:

Leave a Reply

Your email address will not be published. Required fields are marked *

error: Content is protected !!